Reply To: Modify Segments Problem

Home Forums Support Forums TURBOSPLINES Modify Segments Problem Reply To: Modify Segments Problem


Hi Vasileios,

Looking to the image you attached, I see your TurboSplines capsule has very few segments for a value of 1000% in the segments parameter.

So the problem could be one of these two:

1. You are working in a very small scale.
2. The capsule object limitation for height segments.

TurboSplines ‘Segments’ parameter works this way: a value of 100% means the mesh will have 1 segment per unit along the spline. So if the spline has a length of 10 units, then the mesh will have 10 height segments.
So the Segments(%) parameter needs to be adjusted depending on the scale you are working.

TurboSplines does not have selective segmentation like the 3dsmax’s Loft tool. The segments are evenly distributed along the spline.

If your spline has a very small size and length, then the capsule will have vey few segments.

So, if this is the case, try scaling up the spline before creating the TurboSplines mesh. Then re-scale down both the spline and mesh together.

In the particular case of the ‘Capsule’ geometry, 3dsMax’s capsule object has a limitation of 200 height segments maximum. That’s why, if you increase the Segments(%) parameter so that the number of segments exceeds 200, TurboSplines ask you if you want to add a TurboSmooth modifier to the mesh to increase resolution.
This is the recommended solution for this case. Adding a 3dsmax’s Turbosmooth modifier to the mesh, while decresing the ‘Sides’ parameter, will result in a higher segmentation along the spline.

Another solution to this is using a ‘Box’ type of mesh instead of ‘Capsule’ and then add a Turbosmooth modifier on top to increase the general resolution of the mesh while rounding it. The you can increase a bit the ‘Radius’ of the mesh to compensate the loose of volume.

I hope the explanation was clear enough.
Please let me know your opinion.

Hernan Rodenstein.